Degraded performance
Incident Report for SuperPay
Resolved
This incident has been resolved.
Posted Jul 18, 2020 - 00:45 UTC
Monitoring
We're seeing a recovery in connectivity and emails being sent normally. We continue to monitor the situation and we'll let you know if anything changes.
Posted Jul 17, 2020 - 21:50 UTC
Identified
One of our upstream providers is currently experiencing issues resulting in some requests to the dashboard and other services failing. Recurring payments are being processed as normal but email delivery for receipts may be delayed while the issue is being resolved.
Posted Jul 17, 2020 - 21:43 UTC
This incident affected: 💳 Payments, 💻 Dashboard, 👨‍💻 Customer Portal, and 📬 Email Delivery.