Degraded platform performance
Incident Report for SuperPay
Resolved
Our service provider has fixed the issue. We're seeing platform levels return back to normal.
Posted May 30, 2020 - 15:49 UTC
Monitoring
Our hosting and infrastructure partner is currently experiencing a minor outage that is impacting some SuperPay services such as the Dashboard and Customer Portal. Recurring & one-time payments remain unaffected and are being processed as normal. If you have any questions please reach out to support@superpayit.com
Posted May 30, 2020 - 15:43 UTC
This incident affected: 💻 Dashboard and 👨‍💻 Customer Portal.